Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-37984

Upgrade yaml-cpp >= 0.6.0

    XMLWordPrintable

Details

    • Improvement
    • Status: Closed
    • Major - P3
    • Resolution: Fixed
    • None
    • 3.4.22, 3.6.14, 4.1.6, 4.0.11
    • None
    • None
    • Fully Compatible
    • v4.0, v3.6, v3.4
    • Dev Tools 2018-11-19

    Description

      boost::next was previously defined in boost/utility.hpp but were moved in 1.67.0 to boost/next_prior.hpp. yaml-cpp 0.5.3 uses them from boost/utility.hpp but yaml-cpp 0.6.0 removed the dependency on boost altogether, which will benefit both of these third_party upgrades in the future anyway

      Attachments

        Issue Links

          Activity

            People

              mathew.robinson@mongodb.com Mathew Robinson (Inactive)
              mathew.robinson@mongodb.com Mathew Robinson (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: