Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-38164

$or pushdown optimization does not correctly handle $not within an $elemMatch

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Critical - P2
    • Resolution: Fixed
    • 3.6.0, 4.0.0, 4.1.5
    • 3.6.10, 4.0.5, 4.1.7
    • Querying
    • Fully Compatible
    • ALL
    • v4.0, v3.6
    • Query 2018-12-03, Query 2018-12-17

    Description

      CVE-2018-20805

      Title: Invariant with $elemMatch

      Description:
      A user authorized to perform database queries may trigger denial of service by issuing specially crafted queries, which perform an $elemMatch This issue affects: MongoDB Inc. MongoDB Server v4.0 versions prior to 4.0.5; v3.6 versions prior to 3.6.10.

      CVSS score:
      This issue's CVSS:3.1 severity is scored at 6.5 using the following scoring metrics:
      CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

      Affected versions
      MongoDB Inc. MongoDB Server v4.0 versions prior to 4.0.5; v3.6 versions prior to 3.6.10.

      CWE: CWE-834: Excessive Iteration

      Attachments

        Activity

          People

            bernard.gorman@mongodb.com Bernard Gorman
            charlie.swanson@mongodb.com Charlie Swanson
            Votes:
            0 Vote for this issue
            Watchers:
            11 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: