Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-38421

Requirement on cryptography should reflect what is in the toolchain

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major - P3
    • Resolution: Fixed
    • None
    • 3.6.10, 4.0.5
    • Build
    • None
    • Fully Compatible
    • ALL
    • v3.6
    • Dev Tools 2018-12-17
    • 50

    Description

      We currently state a dependency on cryptography 1.7.2 exactly in our requirements file, but the new toolchain only offers 2.0+. As a result, we try to build 1.7.2 but it doesn't work. Instead if trying to fix that, just upgrade the affected branches to want cryptography >= 2.0.

      Attachments

        Activity

          People

            andrew.morrow@mongodb.com Andrew Morrow
            andrew.morrow@mongodb.com Andrew Morrow
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: