Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.5.5
    • Component/s: Geo, Querying
    • Labels:

      Description

      In some cases it would be useful to do combinations of geospatial queries using $or, or $all, to do geospatial union or intersection.

      1. server3984.js
        1 kB
        Benety Goh

        Issue Links

          Activity

          robber Robert Ignacz added a comment -

          It would be useful

          xgen-internal-githook Githook User added a comment -

          Author:

          {u'username': u'benety', u'name': u'Benety Goh', u'email': u'benety@mongodb.com'}

          Message: SERVER-3984 added support for $or and geo queries
          Branch: master
          https://github.com/mongodb/mongo/commit/e34325d78543aca3a9f37469aee64c8a9bd23772

          alonho Alon Horev added a comment - - edited

          This still isn't solved for sharded collections. Should I open another ticket or re-open this one?
          It's easy to reproduce: invoke a $or with two geoWithin on a sharded collection and you'll get: database error: $or may not contain 'special' query

          dan@10gen.com Dan Pasette added a comment -

          Alon Horev, can you open a new ticket please?

          alonho Alon Horev added a comment -

            People

            • Votes:
              34 Vote for this issue
              Watchers:
              34 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since reply:
                1 week, 5 days ago
                Date of 1st Reply: