Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-39928

Stop testing PyMongo with Python 2.6 in drivers-nightly

    XMLWordPrintable

    Details

    • Backwards Compatibility:
      Fully Compatible
    • Operating System:
      ALL
    • Backport Requested:
      v4.2, v4.0, v3.4

      Description

      PyMongo removed support for Python 2.6 in PYTHON-1467:

      [2019/02/28 15:00:41.750] Running auth tests over nossl with python /opt/python/2.6/bin/python
      [2019/02/28 15:00:41.758] + /opt/python/2.6/bin/python -c 'import sys; print(sys.version)'
      [2019/02/28 15:00:41.758] + COVERAGE_OR_PYTHON=/opt/python/2.6/bin/python
      [2019/02/28 15:00:41.758] + COVERAGE_ARGS=
      [2019/02/28 15:00:41.758] + '[' -n '' -a CPython = CPython ']'
      [2019/02/28 15:00:41.758] + /opt/python/2.6/bin/python setup.py clean
      [2019/02/28 15:00:41.772] Traceback (most recent call last):
      [2019/02/28 15:00:41.772]   File "setup.py", line 9, in <module>
      [2019/02/28 15:00:41.772]     raise RuntimeError("Python version >= 2.7 required.")
      [2019/02/28 15:00:41.772] RuntimeError: Python version >= 2.7 required.
      

      https://evergreen.mongodb.com/task/drivers_nightly_4.0_python_driver_linux__os~rhel62_auth~auth_ssl~nossl_python_linux~2.6_test_nightly_replica_set_c592fea5fa07a08a82c7e11f7cddbc0b17a98f40_19_02_28_18_36_08

      We need to remove 2.6 from drivers-nightly-3.4, drivers-nightly-4.0, and drivers-nightly (drivers-nightly-3.6 already doesn't use Python 2.6).

      CC: Bernie Hackett

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: