Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-40958

Deprecate the 'scandata' argument in 'validate'

    • Type: Icon: Improvement Improvement
    • Resolution: Fixed
    • Priority: Icon: Minor - P4 Minor - P4
    • 4.1.14
    • Affects Version/s: None
    • Component/s: Storage
    • Labels:
    • Fully Compatible
    • v4.0, v3.6
    • Execution Team 2019-06-03

      Today, setting scandata to true, sets the ValidateCmdLevel to kValidateRecordStore, which is not checked against anywhere, and therefore unused. We should log a message saying that this argument is deprecated and remove it in a future release.

      Additionally, we can convert the 'validate' command to use IDL.

            Assignee:
            gregory.noma@mongodb.com Gregory Noma
            Reporter:
            gregory.wlodarek@mongodb.com Gregory Wlodarek
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Created:
              Updated:
              Resolved: