Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-41757

Missing dependencies for Python environment, Ubuntu/Debian

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor - P4
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.3.1
    • Component/s: Build
    • Labels:
    • Backwards Compatibility:
      Fully Compatible
    • Sprint:
      Dev Tools 2019-07-01

      Description

      The docs/building.md file needed some updates - libcurl-dev is provided by 3 different packages on Ubuntu and Debian. The Python environment needs openssl-devel/libssl-dev headers in order to successfully build. Finally, about 600 GB are needed it one's building Mongo from a git checkout on a VM or container environment (or a frugal laptop, like my first attempt taught me).

      Not sure how it's done, but the wiki will need to reflect these changes.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              mathew.robinson Mathew Robinson (Inactive)
              Reporter:
              rbanffy Ricardo Bánffy
              Participants:
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: