Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-41898

Rename "userImpersonators" to "runBy" in currentOp

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.2.0-rc4, 4.3.1
    • Component/s: Admin
    • Labels:
      None
    • Backwards Compatibility:
      Minor Change
    • Sprint:
      Security 2019-07-15

      Description

      "impersonators" implies a more general set of functionality than is actually provided when mongos runs commands on shard servers as another user. We should reserve that name for future use, and rename the "userImpersonators" field to "runBy" in currentOp.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: