Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-43070

ZSTD fails to decompress messages for versions < v0.8.0

    • Type: Icon: Bug Bug
    • Resolution: Works as Designed
    • Priority: Icon: Major - P3 Major - P3
    • None
    • Affects Version/s: None
    • Component/s: None
    • Labels:
      None
    • ALL

      Zstd versions less than v0.8.0 fails to decompress messages and gives the server-side error:

      2019-08-27T20:00:50.966+0000 I NETWORK [conn6] DBException handling request, closing client connection: BadValue: Could not decompress message: Unknown frame descriptor

      on Ubuntu 16.04. This was discovered with libmongoc, since it was using whichever version of zstd was installed on the system, and Ubuntu 16.04 comes with version 0.5.1 by default.

            Assignee:
            backlog-server-devtools DO NOT USE - Backlog - Dev Tools
            Reporter:
            clyde.bazile@mongodb.com Clyde Bazile III (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            8 Start watching this issue

              Created:
              Updated:
              Resolved: