Core Server
  1. Core Server
  2. SERVER-4356

Sharded getLastError doesn't wait for all writes to go to all shards

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major - P3 Major - P3
    • Resolution: Gone away
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Sharding
    • Labels:
      None
    • Backport:
      No
    • Operating System:
      ALL
    • # Replies:
      1
    • Last comment by Customer:
      false

      Description

      If do a lot of inserts to a sharded collection really fast, then call getLastError, there can still be some inserts that haven't been processed yet. I have attached a test that reproduces the error, but it is very flaky. So far I haven't been able to make a test that's consistently reproducible. The test is entirely taken from sharding/auth.js, but with all other parts of the test (including all uses of authentication) removed.

      http://buildbot.mongodb.org/builders/Linux%2064-bit%20Legacy/builds/3958/steps/test_3/logs/stdio has the output from a run of sharding/auth.js that failed b/c of this.

      1. fastInsertGLE.js
        1 kB
        Spencer Brody

        Activity

        • Comments
        auto
        added a comment -

        Author:

        {u'login': u'stbrody', u'name': u'Spencer T Brody', u'email': u'spencer@10gen.com'}

        Message: Fix test that's flaky due to SERVER-4356
        Branch: master
        https://github.com/mongodb/mongo/commit/78527f722ea9da5acabea19118ad56006a80d272

        Show
        auto
        added a comment - Author: {u'login': u'stbrody', u'name': u'Spencer T Brody', u'email': u'spencer@10gen.com'} Message: Fix test that's flaky due to SERVER-4356 Branch: master https://github.com/mongodb/mongo/commit/78527f722ea9da5acabea19118ad56006a80d272

          People

          • Assignee:
            Spencer Brody
            Reporter:
            Spencer Brody
            Participants:
            Last commenter:
            Ian Whalen
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since reply:
              2 years, 22 weeks, 2 days ago
              Date of 1st Reply: