Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-44840

Rename MigrationCoordinator to something more useful

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: In Progress
    • Priority: Major - P3
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: 4.3 Desired
    • Component/s: Sharding
    • Labels:
      None

      Description

      Currently MigrationCoordinator is called that because of its (very loose) parallels to the transaction coordinator, but this name is not super clear in terms of what the thing actually does. Once we've implemented the remaining functionality we should revisit this name and either intentionally decide to leave it or change it to something better.

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: