Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-4662

Building large index causes primary to stepdown

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Duplicate
    • Affects Version/s: 2.0.2
    • Fix Version/s: None
    • Component/s: Replication
    • Labels:
      None
    • Operating System:
      Linux

      Description

      We have had several instances where building large indexes causes the primary to become inaccessible and step-down to secondary. This has happened during a copyDatabase command and when it stepped down the copy halted and the primary went into rollback then secondary.

      This happened several times during the copyDatabase and also just during an ensureIndex. I backed one environment we were getting this error on back to 2.0.1 and it completed normally. That part is anecdotal but it did work in that one case. Also, I don't recall seeing this before our upgrade to 2.0.2.

        Issue Links

          Activity

          behackett Bernie Hackett added a comment -

          SERVER-2771 is the clearinghouse for indexing and replication.

          eliot Eliot Horowitz added a comment -

          Is this with auth on?

          eliot Eliot Horowitz added a comment -

          Is this with auth on?

          benwyrosdick Ben Wyrosdick added a comment -

          yes, it is running with auth

          benwyrosdick Ben Wyrosdick added a comment -

          Could this be the issue?

          https://github.com/mongodb/mongo/blob/master/src/mongo/db/repl/manager.cpp#L166

          It looks like it was added between 2.0.1 and 2.0.2

          eliot Eliot Horowitz added a comment -

          No - we know what the issue is and have a fix in the works.
          More info later today.

          benwyrosdick Ben Wyrosdick added a comment -

          any update on this issue?

          eliot Eliot Horowitz added a comment -

          SERVER-4673 is the root cause
          patches are in for it for next releases


            People

            • Votes:
              4 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: