Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-46809

Initial sync should assume resume supported if wire version is newer than 4.4

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.4.0-rc5, 4.7.0
    • Component/s: None
    • Labels:
      None
    • Backwards Compatibility:
      Fully Compatible
    • Operating System:
      ALL
    • Backport Requested:
      v4.4
    • Sprint:
      Repl 2020-04-06, Repl 2020-04-20

      Description

      Initial sync currently checks if the wire version is 4.4 (==WireVersion::RESUMABLE_INITIAL_SYNC) to decide if resume is supported. Since we will presumably allow resumable initial sync from 4.4 nodes to 4.6 nodes (but not 4.2 nodes), this should be greater-than-or-equal-to

        Attachments

          Activity

            People

            Assignee:
            matthew.russotto Matthew Russotto
            Reporter:
            matthew.russotto Matthew Russotto
            Participants:
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: