Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-48039

Unrecognized option: net.ssl.clusterCertificateSelector in MongoDB v4.2

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.2.7, 4.4.0-rc6, 4.7.0
    • Component/s: Security
    • Labels:
      None
    • Backwards Compatibility:
      Fully Compatible
    • Operating System:
      ALL
    • Backport Requested:
      v4.4, v4.2
    • Sprint:
      Security 2020-05-18
    • Case:

      Description

      MongoDB version: 4.2.x

      Platform: Windows

      The deprecated net.ssl.clusterCertificateSelector cannot be used in MongoDB v4.2 on Windows Server. The server will fail to start with an error message Unrecognized option: net.ssl.clusterCertificateSelector.

      Please add this net.ssl.clusterCertificateSelector parameter and all the missing deprecated net.ssl.* parameters to the future release of MongoDB v4.2.

       

      This is similar to SERVER-37222.

        Attachments

          Activity

            People

            Assignee:
            sara.golemon Sara Golemon
            Reporter:
            apinya.tepwankul Apinya Tepwankul
            Participants:
            Votes:
            2 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: