Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-50352

Add understanding of previous syntax for multiversion exclusions

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Critical - P2
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.4.1, 4.7.0
    • Component/s: Testing Infrastructure
    • Labels:
      None
    • Backwards Compatibility:
      Fully Compatible
    • Backport Requested:
      v4.4
    • Sprint:
      STM 2020-08-24
    • Story Points:
      1

      Description

      We'd expected that backporting SERVER-48048 immediately would obviate the need to understand the previous yml syntax, but that doesn't seem to be the case; it looks like we use previous release versions in multiversion tests rather than the tips of other branches.

      We should add back in the logic from earlier CRs of SERVER-48048 to handle this. Right now everything in etc/backports_required_for_multiversion_tests.yml is being unconditionally excluded.

        Attachments

          Activity

            People

            Assignee:
            carl.worley Raiden Worley
            Reporter:
            carl.worley Raiden Worley
            Participants:
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: