Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-50533

Avoid setting requireApiVersion parameter in jstestfuzz

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major - P3
    • Resolution: Fixed
    • None
    • 4.7.0
    • None
    • None
    • Fully Compatible
    • 22

    Description

      If the fuzzer generates a test that calls {"setParameter":1,"requireApiVersion":true}, all subsequent commands fail with "The apiVersion parameter is required". I added the requireApiVersion setParameter in SERVER-49887, we must prevent the fuzzer from enabling it.

      Attachments

        Issue Links

          Activity

            People

              jesse@mongodb.com A. Jesse Jiryu Davis
              jesse@mongodb.com A. Jesse Jiryu Davis
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: