Upon investigation of SERVER-50419, we've discovered that the current implementation does not allow us track commands.hello and commands.isMaster as separate metrics. As a result, instead of aliasing hello to isMaster, we should split the two into separate commands and make isMaster a derived class of hello to allow the commands to share functionality.
In this ticket, we should revert the C++ changes from
SERVER-50640. With hello and isMaster being separate commands, the original implementation of listCommands will return both isMaster and hello.