Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-53540

DBException handling request, closing client connection: ClientDisconnect: operation was interrupted

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Duplicate
    • Affects Version/s: 4.2.8
    • Fix Version/s: None
    • Component/s: Logging
    • Labels:
      None
    • Operating System:
      ALL
    • Case:

      Description

      Hello Team,
      Hope you all are doing well, recently we have faced an issue on our production system wherein mongos stops communicating with cluster and version we are using is 4.2.8.
      wherein we tried login through mongos it was getting stuck on 
      Connecting to 127.0.0.1:27017 and nothing it was moving forward. where we checked the logs on mongos and we found something network error 
      NETWORK [conn1524750] DBException handling request, closing client connection: ClientDisconnect: operation was interrupted.
      we tried restarting mongos and redeploying mongos but still the issue remains
      but it was able to communicate when we perform telnet and everything on all the nodes in shards and config  was intact.
      and we checked the logs on the config server which was giving ssl handshake received but server is started without ssl support mongodb 
      but we are not using certificate/ssl based authentication it is simple key-file based authentication.
      Later on we step down the primary on the config server and everything starts as normal after electing the new primary.

      We found the similar scenarios wherein stepdown/restart config server fix the issue, so do we have any other fix apart from upgrade, this seems to be serious issue kindly let us know.
      MonngoDB version we are using 4.2.8   
      https://jira.mongodb.org/browse/SERVER-47553
      https://jira.mongodb.org/browse/SERVER-48709
      https://jira.mongodb.org/browse/SERVER-52654

       

       

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              edwin.zhou Edwin Zhou
              Reporter:
              sourabh.ghosh@visiblealpha.com Sourabh Ghosh
              Participants:
              Votes:
              2 Vote for this issue
              Watchers:
              7 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: