Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-55036

Initial sync on start without reason

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Incomplete
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Replication, Storage
    • Labels:
      None
    • Operating System:
      ALL
    • Sprint:
      Execution Team 2021-08-09, Execution Team 2021-08-23, Execution Team 2021-09-06, Execution Team 2021-09-20

      Description

      I have a relicaSet with 3 data-bearing nodes and 2 arbiters. During an incomplete index build with problems we decided stop one secondary and do an initial sync for the other secondary. The primary has crushed during a logRotate, but when we tried to restart it he decides to do an initial sync with the message "No recovery needed. Initial sync flag set". Do you have any idea ?

      Mongo version : 4.2.11

      Plateforme : CentOS release 6.3 (Final)

      Storage Engine : WiredTiger

      Data volume > 1T bytes

       

      Best regards

      Benaissa El Khattar

       

       

       

       

       

        Attachments

          Activity

            People

            Assignee:
            pavithra.vetriselvan Pavithra Vetriselvan
            Reporter:
            elkhattarbenaissa@gmail.com Benaissa El KHATTAR
            Participants:
            Votes:
            0 Vote for this issue
            Watchers:
            10 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: