Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-57770

Consider changing the parameter name internalQueryForceClassicEngine

    XMLWordPrintable

Details

    • Task
    • Status: Closed
    • Minor - P4
    • Resolution: Gone away
    • 5.0.0
    • None
    • None
    • None

    Description

      Please consider changing this parameter name:

      internalQueryForceClassicEngine

      Typically, for parameters that would be used externally by customers and documented in our customer facing documentation, we would not document parameters that have "internal" in their name.

      Some ideas for consideration by the server team include:

      1. Naming it:

        queryForceClassicEngine

        and keep the Boolean meaning the same.

      2. Even better, naming it:

        enableEnhancedQueryExecution

        and default it to true to enable (false to disable).

      Attachments

        Issue Links

          Activity

            People

              backlog-query-execution Backlog - Query Execution
              jason.price@mongodb.com Jason Price
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: