Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-58637

Temporarily disable null_query_semantics.js from multiversion passthroughs

    XMLWordPrintableJSON

Details

    • Task
    • Status: Closed
    • Major - P3
    • Resolution: Fixed
    • None
    • 5.0.3, 5.1.0-rc0
    • None
    • None
    • Fully Compatible
    • v5.0
    • Query Execution 2021-07-26
    • 70

    Description

      Right now, the multiversion passthrough suites are testing 4.4/5.1 mixed version clusters. However, null_query_semantics.js tests behaviors added under SERVER-21929 that are present only in the master branch and in 5.0. Therefore, this test should not run in the multiversion passthrough suites until those suites start testing 5.0/5.1 mixed version clusters.

      This can be achieved by tagging the test as requires_fcv_50. Once other work is done to bump the FCV constants and start testing 5.0/5.1 multiversion clusters (see SERVER-56366), then tests with requires_fcv_50 will start running in the multiversion passthroughs again. At some later point, we can then delete the obselete requires_fcv_50 tag.

      Attachments

        Issue Links

          Activity

            People

              david.storch@mongodb.com David Storch
              david.storch@mongodb.com David Storch
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: