Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-60604

Mechanism to see if a user is only using commands in a given API Version

    XMLWordPrintable

Details

    • New Feature
    • Status: Backlog
    • Major - P3
    • Resolution: Unresolved
    • None
    • None
    • None
    • None

    Description

      apiStrict:true allows users to opt-in to only using versioned commands. For some users, rather than only being allowed to use versioned commands, they'd love to know if they're only using versioned commands in their current apiStrict:false workload. We should provide some way of showing users what they're doing that's outside of the versioned API without having to switch the apiStrict:true parameter and then get errors. In other words, provide an easy way for a user to understand whether they're doing unstable things.

      Attachments

        Issue Links

          Activity

            People

              christopher.harris@mongodb.com Christopher Harris
              judah.schvimer@mongodb.com Judah Schvimer
              Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

                Created:
                Updated: