Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-610

Temp Collections for Non Map-Reduce Queries

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Minor - P4
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Querying
    • Labels:
      None
    • Environment:
      All
    • Backwards Compatibility:
      Fully Compatible

      Description

      I would like to request the ability to have the results of a query stored in a temporary collection without using Map/Reduce. The query could be executed and return the name of the temporary collection, and options could be passed to define options of the collection, for instance if it's capped or not.

      There are certain cases where this "query and forget until later" could be quite useful... For instance a long running operation over a large dataset where we don't expect results to get returned immediately. An example of this is providing a custom external DSL for users to perform queries against the database, but the DSL to Javascript translation would be an extremely large overhead in order to leverage Map/Reduce.

      The current workaround for this is to put the query on another long running background process and manually put the results in a new collection, I am just looking for a nice way to simplify this.

        Issue Links

          Activity

          kostya Kostyantin Voz added a comment -

          What if that collections won't be temp ? What if that will be [capped] collections working like views in CouchDB ? That could make possible such a thing : querying data from collection, than creating another collection to save the results, when new data added to source collection, it will be queried with the same query and than if match stored in target collection.

          david.storch David Storch added a comment -

          Durran Jordan, would you say that this is a duplicate of the aggregation framework's $out facility, added for 2.6 under SERVER-3253?

          asya Asya Kamsky added a comment -

          This seems like it can be closed since $out in aggregation allows doing what's described.

          durran.jordan Durran Jordan added a comment - - edited

          Oh yeah - this can be closed as $out covers the use case.

          asya Asya Kamsky added a comment -

          This was resolved via "$out" capability of aggregation framework in 2.6 time frame.


            People

            • Votes:
              6 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: