-
Type: Task
-
Resolution: Gone away
-
Priority: Major - P3
-
None
-
Affects Version/s: None
-
Component/s: None
-
Storage Execution
-
Execution Team 2023-06-12
In SERVER-57250 we are converting the simple ViewsForDatabase struct to a more complex class. This is a great improvement, but there are still some more things we want to do. Copied from review comments:
1)
"I really like separating out ViewsForDatabase into its own thing, but the public variables here bother me. We don't normally have public class variables – only in simple structs, and this type warrants a class with all the other logic. And it's really tricky looking at the .cpp file and discerning that these are class variables without the usual underscore prefix signal – e.g. _viewMap, _ignoreExternChange, etc.
Is there a way we could make these private and add helper functions for access? Like from a brief look at the usage, looks like a clear() function and some getters at least."
2)
"Could we rename 'durable' to 'durableViewCatalog' while we're here?
Seeing durable->iterate(..) in the .cpp file made me go "huh?" Named like a boolean."
- depends on
-
SERVER-57250 CollectionCatalog should handle and own Views instead of ViewCatalog
- Closed