Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-63876

[5.0] Secondary nodes crash when applying collMod with `index.expireAfterSeconds` option

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major - P3
    • Resolution: Fixed
    • 5.0.5
    • 6.0.0-rc0, 5.0.7
    • None
    • None
    • Fully Compatible
    • ALL
    • Execution Team 2022-03-07
    • 127

    Description

      When adding the feature to allow converting an index to ttl in 5.1, we didn't have a guard for earlier versions. We should try to enable the 5.0 secondaries to apply the command while disable the 5.0 primaries to run it.

      Attachments

        Issue Links

          Activity

            People

              yuhong.zhang@mongodb.com Yuhong Zhang
              yuhong.zhang@mongodb.com Yuhong Zhang
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: