Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-67014

Say that "the client driver may require an upgrade" in warning message for deprecated op codes in 5.0

    XMLWordPrintable

Details

    • Improvement
    • Status: Closed
    • Major - P3
    • Resolution: Fixed
    • None
    • 5.0.10
    • None
    • None
    • Fully Compatible
    • QE 2022-06-13

    Description

      Although the deprecated op codes (OP_QUERY, OP_INSERT, etc.) will still work in 5.0, they will stop working upon upgrade to 5.1 or later. Applications using old drivers that are producing this warning message should be encouraged to upgrade the driver. The work for this ticket is to augment the warning message in the logs to include the sentence "The client driver may require an upgrade to ensure compatibility with future server versions."

      Attachments

        Issue Links

          Activity

            People

              david.storch@mongodb.com David Storch
              david.storch@mongodb.com David Storch
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: