Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-7298

thousands of "waiting till out of critical section"

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Incomplete
    • Affects Version/s: 2.2.0
    • Fix Version/s: None
    • Component/s: Sharding
    • Environment:
      linux 64 bit
    • Operating System:
      Linux

      Description

      We are running mongodb v2.2.0 Linux 64 Bit, 3 shards each having 3 nodes.
      One node seemed to be dead, so we restarted it. In the logs we found thousands of "waiting till out of critical section", filling up our logs very fastly and making mongodb inaccessible.
      What does this error mean?
      Here are the logs from the restart, if it matters:
      http://pastebin.com/raw.php?i=cZeRJ7NV

      This happened to other nodes as well already to another time.

      Could it be related to v2.2.0 or to authentification? We're using both since a few time and we encounter this error only since then. Should we downgrade or disable authentification?

        Issue Links

          Activity

          Hide
          kaga kay.agahd added a comment -

          Yes, ok, please follow up the support ticket, so this one can be closed.

          Show
          kaga kay.agahd added a comment - Yes, ok, please follow up the support ticket, so this one can be closed.
          Hide
          tad Tad Marshall added a comment -

          SERVER-7034 is the primary ticket for dealing with this issue. Resolving this one as incomplete for now.

          Show
          tad Tad Marshall added a comment - SERVER-7034 is the primary ticket for dealing with this issue. Resolving this one as incomplete for now.
          Hide
          agiamas alex giamas added a comment -

          Thanks all for the answers, added 7034 to my watch list.

          Show
          agiamas alex giamas added a comment - Thanks all for the answers, added 7034 to my watch list.
          Hide
          k.hodin@criteo.com Klébert Hodin added a comment -

          We don't use authentification and had the same issue after upgrading our whole cluter from 2.0.6 to 2.2.1.

          Show
          k.hodin@criteo.com Klébert Hodin added a comment - We don't use authentification and had the same issue after upgrading our whole cluter from 2.0.6 to 2.2.1.
          Hide
          ian@10gen.com Ian Whalen added a comment -

          Klebert, the issue in question, SERVER-7034, has not yet been resolved (and thus not backported.) Please add yourself as a watcher to SERVER-7034 so that you'll receive an update when it is backported.

          Show
          ian@10gen.com Ian Whalen added a comment - Klebert, the issue in question, SERVER-7034 , has not yet been resolved (and thus not backported.) Please add yourself as a watcher to SERVER-7034 so that you'll receive an update when it is backported.

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since reply:
                2 years, 32 weeks, 6 days ago
                Date of 1st Reply: