Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-77168

mongod crashes when restoring time series collection with auth enabled

    • Type: Icon: Bug Bug
    • Resolution: Fixed
    • Priority: Icon: Major - P3 Major - P3
    • 7.1.0-rc0, 5.0.19, 7.0.0-rc6, 6.0.8
    • Affects Version/s: None
    • Component/s: None
    • Labels:
    • Server Security
    • Fully Compatible
    • v7.0, v6.0, v5.0
    • Security 2023-06-12

      Hi team,

      A user reached out to us on the Community Forums that their mongod is crashing when doing a mongostore against a time series collection. I tried to reproduce the issue on my end as well and found that the mongod indeed crashes with invariant failure and signal 6 under certain scenarios.


      This will happen when:

      • auth is used and
      • mongorestore was called using a file parameter mongorestore --username xx --password xx <file>

      And will not happen when:

      • auth is not used 
      • the file is not specified in mongorestore



      This will also happen on a mongod that is part of a replica set. This appears to affect MongoDB 6.0.1. I also tried with version 5.0.17 as well as 6.0.6 and it affects them too. mongorestore and mongodump versions were 100.6.0 (tried with 100.7.0 as well).


      I'm attaching the code, mongorestore error, logs as well as the forum post of the user who reported the issue.


      Kindly let me know if anything else is required from my end.

        1. mongod.log
          67 kB
        2. repro.sh
          0.9 kB

            sara.golemon@mongodb.com Sara Golemon
            satyam.gupta@mongodb.com Satyam Gupta
            0 Vote for this issue
            7 Start watching this issue