Core Server
  1. Core Server
  2. SERVER-8023

A new server added to a Replica Set Fails to start Replication

    Details

    • Type: Question Question
    • Status: Resolved Resolved
    • Priority: Blocker - P1 Blocker - P1
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0.0, 2.2.2
    • Fix Version/s: None
    • Component/s: Replication/Pairing
    • Labels:
      None
    • Environment:
      The Primary and ARB are 2.0.0 and the new Server is 2.2.2
    • Backport:
      No
    • # Replies:
      6
    • Last comment by Customer:
      true

      Description

      I have tried to start a 2.0.0 Secondary and failed to get the Replication started. Then I updated the Secondary to 2.2.2 and it also fails to replicate.

      What I see is that the OpTime for the Secondary is "stuck" at the time of the "backup". The steps from booting to Secondary look like they happen over time, then the server just never gets "caught up" to the OpTime of the Primary.

        Activity

        Thomas Rueckstiess
        added a comment -

        Hi Edward,

        Could you please log into the primary, run a rs.status() and post the output in a comment? Can we also have a look at the log files of primary and secondary?

        As this is a publicly visible ticket, and you may have confidential information in your log files, you can also upload them to our secure server.

        Please compress your logs before and upload them with the following command:

        scp -P 722 -r <filename> server-8023@www.10gen.com:
        

        Substitute <filename> with the name of the file(s) you want to upload. Note the colon ':' at the end of the command. When you are prompted for a password, please just press ENTER.

        Thanks,
        Thomas

        Show
        Thomas Rueckstiess
        added a comment - Hi Edward, Could you please log into the primary, run a rs.status() and post the output in a comment? Can we also have a look at the log files of primary and secondary? As this is a publicly visible ticket, and you may have confidential information in your log files, you can also upload them to our secure server. Please compress your logs before and upload them with the following command: scp -P 722 -r <filename> server-8023@www.10gen.com: Substitute <filename> with the name of the file(s) you want to upload. Note the colon ':' at the end of the command. When you are prompted for a password, please just press ENTER. Thanks, Thomas
        Edward M. Goldberg
        added a comment -

        I just sent over the LOG files and rs.status();

        Please call me at: 916-202-1600 It will be VERY SLOW to get these reports one at a time each time I read E-Mail...

        Please call any time:
        Cell:     916-202-1600
        Skype:  EdwardMGoldberg

        Edward M. Goldberg
        http://myCloudWatcher.com/
        e.m.g.

        Show
        Edward M. Goldberg
        added a comment - I just sent over the LOG files and rs.status(); Please call me at: 916-202-1600 It will be VERY SLOW to get these reports one at a time each time I read E-Mail... Please call any time: Cell:     916-202-1600 Skype:  EdwardMGoldberg Edward M. Goldberg http://myCloudWatcher.com/ e.m.g.
        Gianfranco Palumbo
        added a comment -

        Are these servers in MMS? If so what's their group name?

        Can you update the ticket with rs.status(); again to see if the secondary is catching up?

        Do you still need a callback?

        Regards

        Show
        Gianfranco Palumbo
        added a comment - Are these servers in MMS? If so what's their group name? Can you update the ticket with rs.status(); again to see if the secondary is catching up? Do you still need a callback? Regards
        Gregor Macadam
        added a comment -

        Hi Edward
        I've sent you a skype request and also I have created SUPPORT-438 where we can continue to discuss this privately - if it turns out there is a bug we can make our findings public on this ticket.
        Thanks
        Gregor

        Show
        Gregor Macadam
        added a comment - Hi Edward I've sent you a skype request and also I have created SUPPORT-438 where we can continue to discuss this privately - if it turns out there is a bug we can make our findings public on this ticket. Thanks Gregor
        Gregor Macadam
        added a comment -
        Show
        Gregor Macadam
        added a comment - Please install mms. http://mms.10gen.com/help/install.html
        Dan Pasette
        added a comment -

        closing; reporter has not responded to follow ups.

        Show
        Dan Pasette
        added a comment - closing; reporter has not responded to follow ups.

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since reply:
              1 year, 3 weeks ago
              Date of 1st Reply: