All other methods have comments explaining their purpose and function in detail, except for current(), which may be misleading.
It may be useful to add a comment and rename it to something unambigious such as peek(), which is a common term for looking at stream/iterator/whatever without advancing it.