Core Server
  1. Core Server
  2. SERVER-9989

rs.status() when issued from a Secondary can still show a Primary with syncingTo

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major - P3 Major - P3
    • Resolution: Fixed
    • Affects Version/s: 2.4.4
    • Fix Version/s: 2.5.1
    • Component/s: None
    • Labels:
      None
    • Backport:
      No
    • Backward Breaking:
      No
    • Operating System:
      ALL
    • Bug Type:
      Unknown
    • # Replies:
      1
    • Last comment by Customer:
      false
    • Steps To Reproduce:
      1. Connect to the Primary
      2. rs.stepDown()
      3. Connect to the new Primary
      4. rs.stepDown()
      5. connect to another secondary
      6. rs.status() will show the old Primary with a syncingTo field
    • Driver changes needed?:
      No driver changes needed

      Description

      If the current Primary of a replica set has been a Secondary in the past, then a rs.status() when issued from a current Secondary will show that Primary with a syncingTo field.

        Activity

        • Comments
        auto
        added a comment -

        Author:

        {u'username': u'dannenberg', u'name': u'matt dannenberg', u'email': u'matt.dannenberg@10gen.com'}

        Message: SERVER-9989 remove syncingTo field from rs.status when that member is no longer syncing from anyone
        Branch: master
        https://github.com/mongodb/mongo/commit/c42fd35a0a0bd5f9511fdcbea4bdc2ec590fddd3

        Show
        auto
        added a comment - Author: {u'username': u'dannenberg', u'name': u'matt dannenberg', u'email': u'matt.dannenberg@10gen.com'} Message: SERVER-9989 remove syncingTo field from rs.status when that member is no longer syncing from anyone Branch: master https://github.com/mongodb/mongo/commit/c42fd35a0a0bd5f9511fdcbea4bdc2ec590fddd3

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since reply:
              43 weeks ago
              Date of 1st Reply: