Uploaded image for project: 'Spark Connector'
  1. Spark Connector
  2. SPARK-117

Mongo-java-driver not compatible with MongoDB 3.4

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Works as Designed
    • Affects Version/s: 2.0.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • # Replies:
      4
    • Last comment by Customer:
      true

      Description

      The connector was compiled with mongo-java-driver 3.2.2 which is not compatible with MongoDB 3.4 : https://docs.mongodb.com/ecosystem/drivers/java/

      It should be compiled with new version of mongo-java-driver 3.4.2
      https://mvnrepository.com/artifact/org.mongodb.spark/mongo-spark-connector_2.10/2.0.0

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since reply:
                2 years, 49 weeks, 2 days ago
                Date of 1st Reply: