The command line argument names for mongoimport are inconsistent and confusing. We use "fields" to specify the column headers inline. We use "fieldFile" to indicate a file which itself contains the column headers as an alternative to "fields". We use "headerLine" to indicate that the column headers are actually at the top of the file we are importing, not to provide the contents of that header itself.
Rename "fields" to "headers"
Rename "fieldFile" to "headerFile"
Rename "headerLine" to "fileHasHeader"