Uploaded image for project: 'MongoDB ETL Tools'
  1. MongoDB ETL Tools
  2. TOOLS-1813

Minimal UUID support for 3.6

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.7.1, 3.6.0-rc5
    • Component/s: None
    • Labels:
      None

      Description

      This is a tracking ticket for TOOLS-1812 in the TOOLS-1735 "Tool 3.6 support" epic, as you can't add an epic to an epic.

      Updated requirements with reduced scope

      There are only two requirements for 3.6 GA; other capabilities post 3.6 GA will be kept in epic TOOLS-1812.

      • mongodump: strip the 'ui' field from oplog entries. This may already be done so just needs testing.
      • mongodump: when dumping the oplog, abort mongodump with an error if a collection rename is seen in the oplog. This does not happen today and needs to be added and tested.

        Attachments

          Activity

            People

            • Assignee:
              gabriel.russell Gabriel Russell
              Reporter:
              david.golden David Golden
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: