Uploaded image for project: 'MongoDB ETL Tools'
  1. MongoDB ETL Tools
  2. TOOLS-1987

Please add support for OpenSSL 1.1

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Duplicate
    • Affects Version/s: 3.6.3
    • Fix Version/s: None
    • Component/s: All Tools
    • Labels:
      None
    • Backport Requested:
      v3.6

      Description

      1. Upgrade spacemonkeygo/openssl to master
      2. Remove usage of openssl.Version, or revert upstream dropping export of OPENSSL_VERSION_TEXT
      3. Fix usage of:
        undefined: openssl.OpAll
        undefined: openssl.FiletypePEM
        undefined: openssl.AutoRetry
        undefined: openssl.LoadClientCAFile

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                david.golden David Golden
                Reporter:
                xnox Dimitri John Ledkov
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: