Uploaded image for project: 'MongoDB Database Tools'
  1. MongoDB Database Tools
  2. TOOLS-2683

Ubuntu 16.04 DB Tools 100.1.0 DEB depends on libcom-err2, should be libcomerr2

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major - P3
    • Resolution: Fixed
    • None
    • 100.1.1
    • None
    • None

    Description

      The 100.1.0 DB Tools DEB file for Ubuntu 16.04, here:

      http://repo.mongodb.org/apt/ubuntu/dists/xenial/mongodb-org/4.4/multiverse/binary-amd64/mongodb-database-tools_100.1.0_amd64.deb

      includes a hard dependency on a libcom-err2 package, but the correct package name is libcomerr2 on Ubuntu 16.04

      I have attached a brief troubleshooting guide, including steps to tweak the prod DEB file and edit the dependency, which seems to fix the problem for Ubuntu 16.04 at least.

      Recommend a brief check to make sure this doesn't affect the other Ubuntu / Deb builds. I did check Ubuntu 20.04 on MDB 4.4, which works just fine, and Ubuntu 16.04 on MDB 4.2 works just fine, but have not checked any others. Only think this affects 4.4 builds released Friday last.

      Thanks to john.williams for the initial find!

      Attachments

        Activity

          People

            patrick.meredith@mongodb.com Patrick Meredith
            andrew.feierabend@mongodb.com Andrew Feierabend (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: