It's not consistent with other checkpoint options in. Sue points out:
- Instead of adding another config option, could we just run the already-existing checkpoint_worker thread/code during populate as well?
- Additionally, that code currently runs on a timer interval rather than number of operations. We could add a general checkpoint_rate option. This would be similar to the sample_interval versus sample_rate that we also have, but either phase would use it.
- If you believe it is worthwhile to have a separate config option as a rate, only for populate, I suggest renaming it to checkpoint_populate_rate so that it sorts next to the other existing checkpoint config strings. Also clarify the existing ones to say they're workload-only related.
- If you have a wtperf config file that you want to add, we should add another Jenkins job to stress that code regularly.