Uploaded image for project: 'WiredTiger'
  1. WiredTiger
  2. WT-147

Allow indices to be created and dropped on non-empty tables

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: WT2.7.0
    • Labels:

      Issue Links

        Activity

        xgen-internal-githook Githook User added a comment -

        Author:

        {u'username': u'michaelcahill', u'name': u'Michael Cahill', u'email': u'michael.cahill@mongodb.com'}

        Message: Merge pull request #2189 from wiredtiger/index-create-lsm3

        WT-147: Dynamic Index creation. Use bulk=unordered
        Branch: develop
        https://github.com/wiredtiger/wiredtiger/commit/959376c602c664dd13ffdd8e59931ae1aa4c89f0

        xgen-internal-githook Githook User added a comment -

        Author:

        {u'username': u'michaelcahill', u'name': u'Michael Cahill', u'email': u'michael.cahill@mongodb.com'}

        Message: SERVER-19954 Don't scan tracked handles during checkpoints.

        The change in WT-147 to allow a session to lock the same handle exclusive multiple times makes this unnecessary.
        Branch: develop
        https://github.com/wiredtiger/wiredtiger/commit/215156b8545a42b8ae878019f1b830debe6f5fa0

        Dmitri Shubin Dmitri Shubin added a comment -

        I can see that now every I time I call WT_SESSION::create("index:my_table:my_index") for full-scan of the main table is performed to fill index table.
        We used to call WT_SESSION::create() for all our tables and indices on each start and now it's not free anymore.

        keith.bostic Keith Bostic added a comment -

        Dmitri Shubin, I'm going to leave WT-147 resolved, and open a new ticket, WT-2295 to handle this question. (In general, new tickets that link to older tickets are easier in our process, sorry!)

        Dmitri Shubin Dmitri Shubin added a comment -

        Well, actually I didn't want to create a case because probably it's desired and expected behaviour.
        Just was surprised a bit...


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since reply:
              1 year, 13 weeks, 5 days ago
              Date of 1st Reply: