@agorrod, I use a stripped-down handle name plus the method names because that's what we did in the WT_CONNECTION.configure_method API, which has the same naming problem and which we solved this way.
I like your idea of using the full cookie and method (for example, WT_SESSION.create) better than what we're doing now; if we switch to that approach, we should convert the WT_CONNECTION.configure_method API as well.
Alternatively, I agree it's not documented anywhere we use stripped-down handle names plus the method names, I can add that documentation.
Users won't change anything other than the configurations associated with our published methods, I can't think of a scenario where a user changing the configuration of table.meta would make sense. We document the argument is "the name of a method", which isn't great documentation, but excludes things like table.meta. We're not exposing any internal naming scheme here, it's simply our internal naming matches method names so we skipped the extra lookup.
I don't understand what you mean by "a set of options for the configuration validation", but using the full handle name and method would mean we no longer expose any internal naming.