Details

    • Type: Task
    • Status: Resolved
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: WT2.6.0
    • Labels:

      Description

      A user reported:

      > Playing a bit with column store I found that if I start record numbers for column store table with some big values then DB close and subsequent open takes huge amount of time.
      > What I wanted to do is to use timestamp (with microsecond precision) as a record number.

      Call stacks during the long startup time:

      #0  0x00007f31bec3629d in __col_var_search (page=0x12717c0, recno=5908978781) at ./src/include/column.i:172
      WT-1  0x00007f31bec36924 in __cursor_var_next (cbt=0x1263d40, newpage=1) at src/btree/bt_curnext.c:192
      WT-2  0x00007f31bec37294 in __wt_btcur_next (cbt=0x1263d40, truncating=0) at src/btree/bt_curnext.c:454
      WT-3  0x00007f31bec80029 in __curfile_next (cursor=0x1263d40) at src/cursor/cur_file.c:113
       
      #0  __wt_vunpack_posint (pp=0x7ffffde922c8, maxlen=0, retp=0x7ffffde92348) at ./src/include/intpack.i:147
      WT-1  0x00007f31bec33f66 in __wt_vunpack_uint (pp=0x7ffffde922c8, maxlen=0, xp=0x7ffffde92348) at ./src/include/intpack.i:271
      WT-2  0x00007f31bec34595 in __wt_cell_unpack_safe (cell=0x127b028, unpack=0x7ffffde92340, end=0x0) at ./src/include/cell.i:622
      WT-3  0x00007f31bec34821 in __wt_cell_unpack (cell=0x127b028, unpack=0x7ffffde92340) at ./src/include/cell.i:710
      WT-4  0x00007f31bec36ace in __cursor_var_next (cbt=0x1263d40, newpage=1) at src/btree/bt_curnext.c:222
      WT-5  0x00007f31bec37294 in __wt_btcur_next (cbt=0x1263d40, truncating=0) at src/btree/bt_curnext.c:454
      WT-6  0x00007f31bec80029 in __curfile_next (cursor=0x1263d40) at src/cursor/cur_file.c:113
      WT-7  0x0000000000400ca2 in main () at column_store.c:75
       
      #0  __cursor_var_next (cbt=0x1263d40, newpage=1) at src/btree/bt_curnext.c:199
      WT-1  0x00007f31bec37294 in __wt_btcur_next (cbt=0x1263d40, truncating=0) at src/btree/bt_curnext.c:454
      WT-2  0x00007f31bec80029 in __curfile_next (cursor=0x1263d40) at src/cursor/cur_file.c:113
      WT-3  0x0000000000400ca2 in main () at column_store.c:75
      

        Issue Links

          Activity

          ramon.fernandez Ramon Fernandez added a comment -

          Additional ticket information from GitHub

          This ticket was referenced in the following commits:
          Dmitri Shubin Dmitri Shubin added a comment - - edited

          Repeat here my comment from GitHub issue – https://github.com/wiredtiger/wiredtiger/issues/1807#issuecomment-97414831

          It looks like the fix is not in 2.5.3
          At least I can reproduce the issue using released tarball – http://source.wiredtiger.com/releases/wiredtiger-2.5.3.tar.bz2

          But it works fine in current 'develop' (61b3f9bbd7db3d2a53a9669239a3c85365128aed)

          alexander.gorrod Alexander Gorrod added a comment -

          > It looks like the fix is not in 2.5.3

          You are right - the fix for this will be in the first 2.6.0 release. Sorry for the confusion.

          Dmitri Shubin Dmitri Shubin added a comment -

          Makes sense to change 'Fix version' field then.

          alexander.gorrod Alexander Gorrod added a comment -

          Has been fixed, but the fix isn't released yet.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since reply:
                2 years, 8 weeks, 2 days ago
                Date of 1st Reply: