Uploaded image for project: 'WiredTiger'
  1. WiredTiger
  2. WT-1808

Avoid a deadlock between the sweep server and a checkpoint.

    Details

    • Type: Task
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: WT2.5.2
    • Labels:

      Description

      The sweep server was holding a handle exclusive and waiting on the handle list lock (in order to remove the handle from the list), a checkpoint was holding the handle list lock waiting for a read lock on the handle. Found by examining a hang during automated testing.

        Issue Links

          Activity

          michael.cahill Michael Cahill added a comment -

          @agorrod, can you please review?

          agorrod Alex Gorrod added a comment -

          autobuild: retest this please

          agorrod Alex Gorrod added a comment -

          Thanks [~michaelcahill] lgtm. I can't reproduce the build failure and it didn't appear to be related to your change (I don't see how it could result in an ENOENT on open). I'll merge and watch Jenkins.

          ramon.fernandez Ramon Fernandez added a comment -

          Additional ticket information from GitHub

          Commits in this ticket:
          This ticket was referenced in the following commits:

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since reply:
                1 year, 49 weeks, 5 days ago
                Date of 1st Reply: