Uploaded image for project: 'WiredTiger'
  1. WiredTiger
  2. WT-1905

Define behavior of cache_resident flag for LSM trees

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor - P4
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: WT2.6.0
    • Labels:
      None
    • # Replies:
      4
    • Last comment by Customer:
      true

      Description

      We have never tested what it means to configure LSM and cache_resident at the same time.

      Configuring both is likely to stop the process of moving the in-memory chunks to disk - limiting the number of chunks to how much fits into cache.

      That may be expected behavior - if so we should consider documenting and close this issue.

        Activity

        michael.cahill Michael Cahill added a comment -

        I think we should disallow cache_resident on LSM trees – I talked this over with Keith Bostic late last week. It doesn't make much sense, since LSM is all about managing data that is too large for cache with sequential I/O.

        alexander.gorrod Alexander Gorrod added a comment -

        The change to implement this is in code review here:
        https://github.com/wiredtiger/wiredtiger/pull/1937

        xgen-internal-githook Githook User added a comment -

        Author:

        {u'username': u'agorrod', u'name': u'Alex Gorrod', u'email': u'alexg@wiredtiger.com'}

        Message: Disallow the cache_resident flag on LSM trees.

        Refs WT-1905
        Branch: develop
        https://github.com/wiredtiger/wiredtiger/commit/3cfca1a09f6f5879f007d51071e4c1feb5d454b9

        alexander.gorrod Alexander Gorrod added a comment -

        Enforced that cache_resident isn't set on LSM trees, and updated documentation.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since reply:
              1 year, 50 weeks, 6 days ago
              Date of 1st Reply: