Uploaded image for project: 'WiredTiger'
  1. WiredTiger
  2. WT-1959

Change block leak to be a verify warning.

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor - P4
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: WT2.7.0
    • Labels:
      None

      Description

      We've seen a few concurrency errors where WiredTiger has leaked a block, and this causes verify to fail.

      This isn't a corruption problem, and so we should change a block leak to be a warning so installations aren't blocked from continuing.

      Add a -strict configuration to verify that makes the warning a fatal error.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                keith.bostic Keith Bostic
                Reporter:
                keith.bostic Keith Bostic
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: