Uploaded image for project: 'WiredTiger'
  1. WiredTiger
  2. WT-1986

Failure of test_txn07 in wiredtiger-unit-test

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: WT2.7.0
    • Labels:
      None

      Description

      Failure is in unit test:
      http://build.wiredtiger.com:8080/job/wiredtiger-test-unit/4179/console

      ======================================================================
      ERROR: test_txn07.test_txn07.test_ops(none.t1r.trunc-start.var) (subunit.RemotedTestCase)
      test_txn07.test_txn07.test_ops(none.t1r.trunc-start.var)
      ----------------------------------------------------------------------
      _StringException: Traceback (most recent call last):
        File "/home/jenkins/jenkins/workspace/wiredtiger-test-unit/test/suite/test_txn07.py", line 164, in test_ops
          c[k] = value
        File "/home/jenkins/jenkins/workspace/wiredtiger-test-unit/lang/python/wiredtiger/__init__.py", line 356, in __setitem__
          if self.insert() != 0:
      WiredTigerError: No such file or directory
      

      Another similar failure has appeared in the past day
      http://build.wiredtiger.com:8080/job/wiredtiger-spinlock-gcc/2362/console

        Issue Links

          Activity

          david.hows David Hows added a comment -

          More digging with verbose logging showed that we were allocating log files twice.

          I think the issue relates to: https://github.com/wiredtiger/wiredtiger/commit/d112c3ab999d0ad65cc2e5bb56aa8e6f52190083

          I've made a test reverting this change and that seems to have solved things.

          xgen-internal-githook Githook User added a comment -

          Author:

          {u'username': u'michaelcahill', u'name': u'Michael Cahill', u'email': u'michael.cahill@mongodb.com'}

          Message: WT-1986 Fix a race renaming temporary log files.
          Branch: develop
          https://github.com/wiredtiger/wiredtiger/commit/bd90f45ca8b4d9e4f3b6cbf1be1427442251c28d

          xgen-internal-githook Githook User added a comment -

          Author:

          {u'username': u'michaelcahill', u'name': u'Michael Cahill', u'email': u'michael.cahill@mongodb.com'}

          Message: WT-1986 Fix a race renaming temporary log files into place.
          Branch: develop
          https://github.com/wiredtiger/wiredtiger/commit/596ffc29b874cdd7d4ada25b1c8be61d1a2a5638

          xgen-internal-githook Githook User added a comment -

          Author:

          {u'username': u'agorrod', u'name': u'Alex Gorrod', u'email': u'alexander.gorrod@mongodb.com'}

          Message: Merge pull request #2040 from wiredtiger/log-tmpfile-race

          WT-1986 Fix a race renaming temporary log files.
          Branch: develop
          https://github.com/wiredtiger/wiredtiger/commit/9897eb2253c6cccab3b1e5640b4474e4f35c5b91

          david.hows David Hows added a comment -

          20 runs of test_txn07 with the patch and I was unable to reproduce the error.


            People

            • Assignee:
              david.hows David Hows
              Reporter:
              david.hows David Hows
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: