Uploaded image for project: 'WiredTiger'
  1. WiredTiger
  2. WT-1998

Schema format with multiplier has problem with indices

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: WT2.7.0
    • Fix Version/s: WT2.7.0
    • Labels:
      None
    • # Replies:
      4
    • Last comment by Customer:
      true

      Description

      Creating a main table with value_format '3i', and then creating an index on those three columns yields an index with a key_format: '3i3i3i', rather than expected '3i'. See attached example program.

      1. ex_schema_mult.c
        3 kB
        Donald Anderson

        Activity

        xgen-internal-githook Githook User added a comment -

        Author:

        {u'username': u'michaelcahill', u'name': u'Michael Cahill', u'email': u'michael.cahill@mongodb.com'}

        Message: WT-1998 WT-2000 Fixes for indexes with some rarely used key/value formats.
        Branch: develop
        https://github.com/wiredtiger/wiredtiger/commit/5a5481b93c88bffac11f92638e77da877cd7263a

        xgen-internal-githook Githook User added a comment -

        Author:

        {u'username': u'ddanderson', u'name': u'Don Anderson', u'email': u'dda@ddanderson.com'}

        Message: WT-1998, WT-2000. Enabled tests for these packing format fixes.
        Branch: develop
        https://github.com/wiredtiger/wiredtiger/commit/8099d8fa6439ba0f1f2e67990522ead40bf62966

        xgen-internal-githook Githook User added a comment -

        Author:

        {u'username': u'ddanderson', u'name': u'Don Anderson', u'email': u'dda@mongodb.com'}

        Message: Merge pull request #2050 from wiredtiger/index-format-fixes

        WT-1998 WT-2000 Fixes for indexes with some rarely used key/value formats
        Branch: develop
        https://github.com/wiredtiger/wiredtiger/commit/144a383393d3ee158d4b3e364f45aec8653f8db8

        donald.anderson Donald Anderson added a comment -

        Confirmed fixed by code merge.
        Changes to test/suite/test_pack.py confirm the fix.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since reply:
              1 year, 51 weeks ago
              Date of 1st Reply: