Uploaded image for project: 'WiredTiger'
  1. WiredTiger
  2. WT-2097

Performance regression in wtperf evict-btree job

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: WT2.7.0
    • Labels:
      None
    • # Replies:
      3
    • Last comment by Customer:
      true

      Description

      Jenkins is showing a performance regression in the wtperf evict btree job:
      http://build.wiredtiger.com:8080/job/wiredtiger-perf-evict-btree/

      The degradation is around 20%, and there is more variability in the run.

        Issue Links

          Activity

          alexander.gorrod Alexander Gorrod added a comment -

          My local testing shows that reverting the "goto stall" part of this change:
          https://github.com/wiredtiger/wiredtiger/commit/0af2b62e6fa8abb968f0847691f18e5b9c79b11f

          Improves performance. In my local testing the throughput goes from 448k ops/sec to 1700 ops/sec by not busy waiting in the loop. I'll push a branch.

          xgen-internal-githook Githook User added a comment -

          Author:

          {u'username': u'agorrod', u'name': u'Alex Gorrod', u'email': u'alexg@wiredtiger.com'}

          Message: WT-2097 Reintroduce immediate waits when forced eviction is necessary.

          Reverts part of 0af2b62e6fa8abb968f0847691f18e5b9c79b11f
          Branch: develop
          https://github.com/wiredtiger/wiredtiger/commit/1e27ccaad28f678b23583ff7e804b7e6a2e5f06d

          xgen-internal-githook Githook User added a comment -

          Author:

          {u'username': u'michaelcahill', u'name': u'Michael Cahill', u'email': u'michael.cahill@mongodb.com'}

          Message: Merge pull request #2181 from wiredtiger/stall-for-forced-eviction

          WT-2097 Reintroduce immediate waits when forced eviction is necessary.
          Branch: develop
          https://github.com/wiredtiger/wiredtiger/commit/90082602505f8954698252b13913a7ef1f250222


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since reply:
                1 year, 36 weeks, 5 days ago
                Date of 1st Reply: