Uploaded image for project: 'WiredTiger'
  1. WiredTiger
  2. WT-2156

Segfault during connection close in eviction server

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: WT2.7.0
    • Labels:
      None
    • # Replies:
      3
    • Last comment by Customer:
      true

      Description

      The failure has appeared several times in Jenkins, including:
      http://build.wiredtiger.com:8080/job/wiredtiger-test-format-stress/8568/console

      Started suspiciously after:
      https://github.com/wiredtiger/wiredtiger/pull/2234

      The configuration from the above failure reproduces a crash reliably for me.

      ############################################
      #  RUN PARAMETERS
      ############################################
      abort=0
      auto_throttle=1
      firstfit=0
      bitcnt=2
      bloom=1
      bloom_bit_count=58
      bloom_hash_count=23
      bloom_oldest=0
      cache=150
      checkpoints=1
      checksum=uncompressed
      chunk_size=5
      compaction=0
      compression=none
      data_extend=0
      data_source=lsm
      delete_pct=15
      dictionary=0
      encryption=none
      evict_max=2
      file_type=row-store
      backups=0
      huffman_key=0
      huffman_value=0
      insert_pct=58
      internal_key_truncation=0
      internal_page_max=12
      isolation=read-committed
      key_gap=19
      key_max=105
      key_min=24
      leak_memory=0
      leaf_page_max=17
      logging=1
      logging_compression=snappy
      logging_archive=0
      logging_prealloc=1
      long_running_txn=0
      lsm_worker_threads=4
      merge_max=10
      mmap=1
      ops=100000
      prefix_compression=1
      prefix_compression_min=3
      repeat_data_pct=23
      reverse=0
      rows=100000
      runs=100
      salvage=1
      split_pct=83
      statistics=0
      statistics_server=0
      threads=31
      timer=20
      value_max=3394
      value_min=1
      verify=1
      wiredtiger_config=
      write_pct=34
      ############################################
      

        Issue Links

          Activity

          xgen-internal-githook Githook User added a comment -

          Author:

          {u'username': u'michaelcahill', u'name': u'Michael Cahill', u'email': u'michael.cahill@mongodb.com'}

          Message: WT-2149 WT-2156 Allow eviction workers to restart.
          Branch: develop
          https://github.com/wiredtiger/wiredtiger/commit/2c6072d869d0945812af49aaa8ba0613565f9284

          xgen-internal-githook Githook User added a comment -

          Author:

          {u'username': u'agorrod', u'name': u'Alex Gorrod', u'email': u'alexander.gorrod@mongodb.com'}

          Message: Merge pull request #2240 from wiredtiger/WT-2156

          WT-2149 WT-2156 Allow eviction workers to restart.
          Branch: develop
          https://github.com/wiredtiger/wiredtiger/commit/cc42bda7c56e40d743eeaa4240665844293778b8

          xgen-internal-githook Githook User added a comment -

          Author:

          {u'username': u'agorrod', u'name': u'Alex Gorrod', u'email': u'alexander.gorrod@mongodb.com'}

          Message: Merge pull request #2240 from wiredtiger/WT-2156

          WT-2149 WT-2156 Allow eviction workers to restart.
          Branch: develop
          https://github.com/wiredtiger/wiredtiger/commit/cc42bda7c56e40d743eeaa4240665844293778b8


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since reply:
                1 year, 25 weeks, 5 days ago
                Date of 1st Reply: