Uploaded image for project: 'WiredTiger'
  1. WiredTiger
  2. WT-2185

Segfault with combination of overflow items and parent split

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: WT2.7.0
    • Labels:
      None
    • # Replies:
      3
    • Last comment by Customer:
      true

      Description

      Jenkins failed with a segfault. Failure here:
      http://build.wiredtiger.com:8080/job/wiredtiger-test-format/4573

      Stack trace:

      Backtrace:
      /mnt/fast/jenkins/workspace/wiredtiger-test-format/build_posix/../src/include/gcc.h:133(__wt_atomic_fetch_add16)[0x437a67]
      /mnt/fast/jenkins/workspace/wiredtiger-test-format/build_posix/../src/btree/bt_ovfl.c:251(__wt_ovfl_discard)[0x47828a]
      /mnt/fast/jenkins/workspace/wiredtiger-test-format/build_posix/../src/btree/bt_split.c:1152(__split_parent)[0x483a2e]
      /mnt/fast/jenkins/workspace/wiredtiger-test-format/build_posix/../src/btree/bt_split.c:965(__split_parent_unlock)[0x485bab]
      /mnt/fast/jenkins/workspace/wiredtiger-test-format/build_posix/../src/evict/evict_page.c:163(__evict_reverse_split_check)[0x421695]
      /mnt/fast/jenkins/workspace/wiredtiger-test-format/build_posix/../src/evict/evict_file.c:95(__wt_evict_file)[0x4b4acf]
      /mnt/fast/jenkins/workspace/wiredtiger-test-format/build_posix/../src/btree/bt_sync.c:262(__wt_cache_op)[0x48827a]
      /mnt/fast/jenkins/workspace/wiredtiger-test-format/build_posix/../src/conn/conn_dhandle.c:198(__wt_conn_btree_sync_and_close)[0x49f157]
      /mnt/fast/jenkins/workspace/wiredtiger-test-format/build_posix/../src/conn/conn_sweep.c:178(__sweep_discard_trees)[0x41783f]
      /lib64/libpthread.so.0(+0x7df3)[0x7f9289f71df3]
      /lib64/libc.so.6(clone+0x6d)[0x7f9289c9f1ad]
      

      test/format configuration file:

      ############################################
      #  RUN PARAMETERS
      ############################################
      abort=0
      auto_throttle=1
      firstfit=0
      bitcnt=4
      bloom=1
      bloom_bit_count=39
      bloom_hash_count=4
      bloom_oldest=0
      cache=300
      checkpoints=1
      checksum=uncompressed
      chunk_size=10
      compaction=0
      compression=none
      data_extend=0
      data_source=lsm
      delete_pct=24
      dictionary=0
      encryption=rotn-7
      evict_max=0
      file_type=row-store
      backups=0
      huffman_key=0
      huffman_value=0
      insert_pct=60
      internal_key_truncation=0
      internal_page_max=9
      isolation=snapshot
      key_gap=19
      key_max=68
      key_min=31
      leak_memory=0
      leaf_page_max=11
      logging=0
      logging_compression=none
      logging_archive=1
      logging_prealloc=1
      long_running_txn=0
      lsm_worker_threads=4
      merge_max=12
      mmap=1
      ops=1000
      prefix_compression=1
      prefix_compression_min=6
      repeat_data_pct=8
      reverse=0
      rows=10000
      runs=50
      salvage=1
      split_pct=81
      statistics=1
      statistics_server=0
      threads=1
      timer=20
      value_max=1356
      value_min=5
      verify=1
      wiredtiger_config=
      write_pct=87
      ############################################
      

      Reproduced after 4 runs for me.

        Activity

        xgen-internal-githook Githook User added a comment -

        Author:

        {u'username': u'agorrod', u'name': u'Alex Gorrod', u'email': u'alexg@wiredtiger.com'}

        Message: WT-2185: Don't do reverse splits when closing a file.

        The ovfl_lock may already have been freed.
        Branch: develop
        https://github.com/wiredtiger/wiredtiger/commit/06b5b8bea92c056e8540082ab4efb2c2df4883ac

        xgen-internal-githook Githook User added a comment -

        Author:

        {u'username': u'michaelcahill', u'name': u'Michael Cahill', u'email': u'michael.cahill@mongodb.com'}

        Message: Merge pull request #2270 from wiredtiger/WT-2185

        WT-2185: Don't do reverse splits when closing a file.
        Branch: develop
        https://github.com/wiredtiger/wiredtiger/commit/9584be3a9084db151271d2f5c6e77c3e1b05c29d

        xgen-internal-githook Githook User added a comment -

        Author:

        {u'username': u'michaelcahill', u'name': u'Michael Cahill', u'email': u'michael.cahill@mongodb.com'}

        Message: Merge pull request #2270 from wiredtiger/WT-2185

        WT-2185: Don't do reverse splits when closing a file.
        Branch: develop
        https://github.com/wiredtiger/wiredtiger/commit/9584be3a9084db151271d2f5c6e77c3e1b05c29d


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since reply:
              1 year, 34 weeks ago
              Date of 1st Reply: