Uploaded image for project: 'WiredTiger'
  1. WiredTiger
  2. WT-2372

WiredTiger windows builder fails with C4005 against the "inline" macro

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: WT2.8.0
    • Labels:
      None
    • # Replies:
      29
    • Last comment by Customer:
      true

      Description

      WiredTiger windows builder fails with C4005 against the "inline" macro.

      Likely this is caused by the change from the C++ compiler to the C compiler.

        Issue Links

          Activity

          xgen-internal-githook Githook User added a comment -

          Author:

          {u'username': u'daveh86', u'name': u'David Hows', u'email': u'howsdav@gmail.com'}

          Message: WT-2372 - replace the C++ cstdlib include with C stdlib.h
          Branch: mongodb-3.2
          https://github.com/wiredtiger/wiredtiger/commit/35c0842817b073f4f8887d08cdaba686a4256f42

          xgen-internal-githook Githook User added a comment -

          Author:

          {u'username': u'daveh86', u'name': u'David Hows', u'email': u'howsdav@gmail.com'}

          Message: WT-2372 - Remove unnecessary headers
          Branch: mongodb-3.2
          https://github.com/wiredtiger/wiredtiger/commit/cfeb0ebfa44a6b8ab9ea089881cc3e77cad175cd

          xgen-internal-githook Githook User added a comment -

          Author:

          {u'username': u'agorrod', u'name': u'Alex Gorrod', u'email': u'alexander.gorrod@mongodb.com'}

          Message: Merge pull request #2472 from wiredtiger/WT-2372

          WT-2372 - Fix windows inline define, changes for wt_internal inclusion
          Branch: mongodb-3.2
          https://github.com/wiredtiger/wiredtiger/commit/9f10e410fc8ecd0c9a610eb726c17b2d0e28a097

          xgen-internal-githook Githook User added a comment -

          Author:

          {u'username': u'agorrod', u'name': u'Alex Gorrod', u'email': u'alexander.gorrod@mongodb.com'}

          Message: Merge pull request #2472 from wiredtiger/WT-2372

          WT-2372 - Fix windows inline define, changes for wt_internal inclusion
          Branch: mongodb-3.2
          https://github.com/wiredtiger/wiredtiger/commit/9f10e410fc8ecd0c9a610eb726c17b2d0e28a097

          xgen-internal-githook Githook User added a comment -

          Author:

          {u'name': u'Ramon Fernandez', u'email': u'ramon@mongodb.com'}

          Message: Import wiredtiger-wiredtiger-2.7.0-650-g5cdd3e3.tar.gz from wiredtiger branch mongodb-3.2

          ref: 07966a4..5cdd3e3

          SERVER-22437 Coverity analysis defect 77704: Redundant test
          SERVER-22438 Coverity analysis defect 77705: Dereference before null check
          SERVER-22676 WiredTiger fails to open databases created by 3.0.0 or 3.0.1
          WT-2130 Improve on-disk page utlilization with random workloads
          WT-2215 WT_LSN needs to support atomic reads and updates
          WT-2295 WT_SESSION.create does a full-scan of the main table
          WT-2352 Allow build and test without requiring lz4
          WT-2356 log scan advances to next log file on partially written record
          WT-2363 Remove built in support for bzip2
          WT-2368 row-store can pass garbage keys to collator functions
          WT-2369 Use C compiler to detect headers instead of C++ compiler
          WT-2371 parent split cannot access the page after page-index swap
          WT-2372 WiredTiger windows builder fails with C4005 against the "inline" macro
          WT-2377 WTPERF doesn't compile in Windows under MSVC
          WT-2378 Tasks time out on LSM builder
          WT-2397 Cursor traversal from end of the tree skips records.
          WT-60 Big endian port
          Branch: v3.2
          https://github.com/mongodb/mongo/commit/f77630a9e971cae1f921292ea31d9d40a4b096b8


            People

            • Assignee:
              david.hows David Hows
              Reporter:
              david.hows David Hows
              Participants:
              Last commenter:
              Githook User
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since reply:
                1 year, 4 weeks, 1 day ago
                Date of 1st Reply: