Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major - P3
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: WT2.9.0, 3.2.10, 3.3.14
    • Labels:
      None
    • # Replies:
      9
    • Last comment by Customer:
      true

      Description

      Several test/format jobs failed overnight with a stuck cache after the latest code changes. This one on zseries is reproducible elsewhere. I hit it on AWS within 10 iterations. This is changeset e189aa8a.
      http://build.wiredtiger.com:8080/job/wiredtiger-test-format-stress-zseries/10198/

        Issue Links

          Activity

          sue.loverso Sue LoVerso added a comment -

          Here's the CONFIG:

          ############################################
          #  RUN PARAMETERS
          ############################################
          abort=0
          auto_throttle=1
          backups=0
          bitcnt=1
          bloom=1
          bloom_bit_count=38
          bloom_hash_count=27
          bloom_oldest=0
          cache=66
          checkpoints=1
          checksum=on
          chunk_size=9
          compaction=0
          compression=zlib
          data_extend=0
          data_source=file
          delete_pct=10
          dictionary=0
          direct_io=0
          encryption=none
          evict_max=3
          file_type=variable-length column-store
          firstfit=0
          huffman_key=0
          huffman_value=0
          in_memory=0
          insert_pct=23
          internal_key_truncation=1
          internal_page_max=9
          isolation=snapshot
          key_gap=7
          key_max=117
          key_min=29
          leaf_page_max=15
          leak_memory=0
          logging=0
          logging_archive=1
          logging_compression=none
          logging_prealloc=0
          long_running_txn=0
          lsm_worker_threads=3
          merge_max=14
          mmap=1
          ops=100000
          prefix_compression=1
          prefix_compression_min=3
          quiet=1
          repeat_data_pct=43
          reverse=0
          rows=100000
          runs=100
          rebalance=1
          salvage=1
          split_pct=66
          statistics=0
          statistics_server=0
          threads=7
          timer=20
          transaction-frequency=72
          value_max=4028
          value_min=5
          verify=1
          wiredtiger_config=
          write_pct=74
          ############################################
          

          The cache is 66Mb and we fail with it stuck with only 13Mb in use.

          [1473864191:796034][22810:0x7f29feffd700], t, eviction-server: Cache stuck for too long, giving up: Connection timed out
          ==========
          cache dump
          file:wt(<live>): 
          	internal: 4 pages, 0MB, 4/0 clean/dirty pages, 0/0 clean/dirty MB, 0MB max page, 0MB max dirty page
          	leaf: 79 pages, 12MB, 6/73 clean/dirty pages, 0/12 clean/dirty MB, 0MB max page, 0MB max dirty page
          file:WiredTigerLAS.wt(<live>): 
          	internal: 1 pages, 0MB, 0/1 clean/dirty pages, 0/0 clean/dirty MB, 0MB max page, 0MB max dirty page
          file:WiredTiger.wt(<live>): 
          	internal: 1 pages, 0MB, 1/0 clean/dirty pages, 0/0 clean/dirty MB, 0MB max page, 0MB max dirty page
          cache dump: total found = 13MB vs tracked inuse 13MB
          total dirty bytes = 12MB
          ==========
          

          sue.loverso Sue LoVerso added a comment -

          The unit tests of Evergreen on Solaris also failed with a stuck cache for test_bug011.

          ...
           [2016/09/14 01:04:21.347] file:WiredTiger.wt(<live>):
           [2016/09/14 01:04:21.347] 	internal: 1 pages, 0MB, 1/0 clean/dirty pages, 0/0 clean/dirty MB, 0MB max page, 0MB max dirty page
           [2016/09/14 01:04:21.347] 	leaf: 1 pages, 0MB, 0/1 clean/dirty pages, 0/0 clean/dirty MB, 0MB max page, 0MB max dirty page
           [2016/09/14 01:04:21.347] cache dump: total found = 9MB vs tracked inuse 9MB
           [2016/09/14 01:04:21.347] total dirty bytes = 8MB
           [2016/09/14 01:04:21.347] ==========
           [2016/09/14 01:04:21.545] test_bug011.test_bug011.test_eviction (subunit.RemotedTestCase)
           [2016/09/14 01:04:21.546] test_bug011.test_bug011.test_eviction ... ERROR
          

          sue.loverso Sue LoVerso added a comment -

          I confirmed that the issue is with the new changes from WT-2902. Running changeset 09f65fffa737 just before that merge runs the 100 iterations to completion.

          david.hows David Hows added a comment -

          Had the spinlock code stuck in the unit-tests, specifically test_compact02.

          Traces from GDB are:

          Thread 3 (Thread 0x7f0100da9700 (LWP 25405)):
          #0  0x00007f010d3403c3 in select () from /lib64/libc.so.6
          #1  0x00007f0103ac56be in __wt_sleep (seconds=<optimized out>, micro_seconds=<optimized out>) at ../src/os_posix/os_sleep.c:23
          #2  0x00007f0103aa1f15 in __evict_exclusive (ref=<optimized out>, session=<optimized out>) at ../src/evict/evict_page.c:49
          #3  __evict_review (closing=false, flagsp=<synthetic pointer>, ref=0x1fcdc80, session=0x2533ae0) at ../src/evict/evict_page.c:418
          #4  __wt_evict (session=0x2533ae0, ref=0x1fcdc80, closing=false) at ../src/evict/evict_page.c:138
          #5  0x00007f0103a9ee6d in __evict_page (session=0x2533ae0, is_server=<optimized out>) at ../src/evict/evict_lru.c:1713
          #6  0x00007f0103aa03a6 in __evict_lru_pages (is_server=<optimized out>, session=<optimized out>) at ../src/evict/evict_lru.c:827
          #7  __evict_pass (session=<optimized out>) at ../src/evict/evict_lru.c:569
          #8  __evict_server (did_work=<synthetic pointer>, session=<optimized out>) at ../src/evict/evict_lru.c:306
          #9  __wt_evict_thread_run (session=<optimized out>, thread=0x2f5c5c0) at ../src/evict/evict_lru.c:242
          #10 0x00007f0103b00e2d in __wt_thread_run (arg=0x2f5c5c0) at ../src/support/thread_group.c:25
          #11 0x00007f010dd24dc5 in start_thread () from /lib64/libpthread.so.0
          #12 0x00007f010d348c9d in clone () from /lib64/libc.so.6
           
          Thread 2 (Thread 0x7f01005a8700 (LWP 25406)):
          #0  0x00007f010dd28a82 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
          #1  0x00007f0103ac5421 in __wt_cond_wait_signal (session=0x2533e20, cond=0x2e2e760, usecs=<optimized out>, signalled=0x7f01005a7edf) at ../src/os_posix/os_mtx_cond.c:71
          #2  0x00007f0103a7ce47 in __wt_cond_wait (usecs=10000000, cond=<optimized out>, session=0x2533e20) at ../src/include/misc.i:18
          #3  __sweep_server (arg=0x2533e20) at ../src/conn/conn_sweep.c:272
          #4  0x00007f010dd24dc5 in start_thread () from /lib64/libpthread.so.0
          #5  0x00007f010d348c9d in clone () from /lib64/libc.so.6
           
          Thread 1 (Thread 0x7f010e4ea740 (LWP 17841)):
          #0  0x00007f010dd28a82 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
          #1  0x00007f0103ac5421 in __wt_cond_wait_signal (session=0x2534160, cond=0x13db0a0, usecs=<optimized out>, signalled=0x7ffd92d5323f) at ../src/os_posix/os_mtx_cond.c:71
          #2  0x00007f0103a9fa7d in __wt_cond_wait (usecs=10000, cond=<optimized out>, session=0x2534160) at ../src/include/misc.i:18
          #3  __wt_cache_eviction_worker (session=0x2534160, busy=true, pct_full=<optimized out>) at ../src/evict/evict_lru.c:1808
          #4  0x00007f0103a4b8a7 in __wt_cache_eviction_check (didworkp=0x0, busy=true, session=0x2534160) at ../src/include/cache.i:355
          #5  __wt_page_in_func (session=0x2534160, ref=0x321f2b0, flags=4398) at ../src/btree/bt_read.c:506
          #6  0x00007f0103a611bb in __wt_page_swap_func (flags=4398, want=0x321f2b0, held=0x1fcdc80, session=0x2534160) at ../src/include/btree.i:1349
          #7  __tree_walk_internal (session=<optimized out>, refp=0x7ffd92d53410, walkcntp=0x0, skipleafcntp=0x0, flags=4138) at ../src/btree/bt_walk.c:530
          #8  0x00007f0103a2c6d2 in __wt_compact (session=0x2534160, cfg=<optimized out>) at ../src/btree/bt_compact.c:139
          #9  0x00007f0103af5843 in __compact_file (cfg=0x7ffd92d534b0, session=0x2534160) at ../src/session/session_compact.c:235
          #10 __wt_session_compact (wt_session=0x2534160, uri=<optimized out>, config=<optimized out>) at ../src/session/session_compact.c:312
          #11 0x00007f0103d4926e in _wrap_Session_compact (self=<optimized out>, args=<optimized out>) at wiredtiger_wrap.c:6294
          #12 0x00007f010e008b49 in PyEval_EvalFrameEx () from /usr/lib64/libpython2.6.so.1.0
          .....
          

          xgen-internal-githook Githook User added a comment -

          Author:

          {u'username': u'michaelcahill', u'name': u'Michael Cahill', u'email': u'michael.cahill@mongodb.com'}

          Message: WT-2913 Re-sort eviction queues if we find no new candidates. (#3043)

          We could be in a situation with a tiny number of pages in cache, all of
          which are already queued. The queue needs to be re-sorted so that some
          of those entries can become candidates. This caused hangs in some
          test/format configs.
          Branch: develop
          https://github.com/wiredtiger/wiredtiger/commit/1c4d75fe92716950d50a05ddceda5b0cfbedbb17

          xgen-internal-githook Githook User added a comment -

          Author:

          {u'username': u'michaelcahill', u'name': u'Michael Cahill', u'email': u'michael.cahill@mongodb.com'}

          Message: WT-2913 Re-sort eviction queues if we find no new candidates. (#3043)

          We could be in a situation with a tiny number of pages in cache, all of
          which are already queued. The queue needs to be re-sorted so that some
          of those entries can become candidates. This caused hangs in some
          test/format configs.
          Branch: mongodb-3.4
          https://github.com/wiredtiger/wiredtiger/commit/1c4d75fe92716950d50a05ddceda5b0cfbedbb17

          xgen-internal-githook Githook User added a comment -

          Author:

          {u'username': u'agorrod', u'name': u'Alex Gorrod', u'email': u'alexander.gorrod@mongodb.com'}

          Message: Import wiredtiger: 5bc03723a7e77c96b1d5e45a97173654872c727a from branch mongodb-3.4

          ref: deeb0f589a..5bc03723a7
          for: 3.3.13

          WT-2859 Improve statistics macros to not collect stats when statistics=none is set
          WT-2894 Create workload that shows negative scaling when overwhelmed
          WT-2900 Add ARM8 build support to WiredTiger and fix ARM CRC assembler tags
          WT-2902 Enhance eviction to work better with update heavy YCSB load
          WT-2905 dead code: MongoDB Coverity #99881
          WT-2908 Add dry-run support to python unit-test
          WT-2910 test_inmem01 can abort due to stuck cache
          WT-2911 add support for gcc6
          WT-2912 make --enable-strict run on the zseries test box
          WT-2913 stuck cache after latest merge
          WT-2914 Fix link error on OS/X for checksum_init call
          WT-2916 whitespace check not working
          Branch: master
          https://github.com/mongodb/mongo/commit/7693fa59c4470db729d85af99fb9cc3b264fa8c8

          xgen-internal-githook Githook User added a comment -

          Author:

          {u'username': u'michaelcahill', u'name': u'Michael Cahill', u'email': u'michael.cahill@mongodb.com'}

          Message: WT-2913 Re-sort eviction queues if we find no new candidates. (#3043)

          We could be in a situation with a tiny number of pages in cache, all of
          which are already queued. The queue needs to be re-sorted so that some
          of those entries can become candidates. This caused hangs in some
          test/format configs.
          Branch: mongodb-3.2
          https://github.com/wiredtiger/wiredtiger/commit/1c4d75fe92716950d50a05ddceda5b0cfbedbb17

          xgen-internal-githook Githook User added a comment -

          Author:

          {u'username': u'michaelcahill', u'name': u'Michael Cahill', u'email': u'michael.cahill@mongodb.com'}

          Message: Import wiredtiger: bb18c439152379fb528af217345be40819b01fc4 from branch mongodb-3.2

          ref: 911c940ada..bb18c43915
          for: 3.2.10

          WT-2859 Improve statistics macros to not collect stats when statistics=none is set
          WT-2894 Create workload that shows negative scaling when overwhelmed
          WT-2900 Add ARM8 build support to WiredTiger and fix ARM CRC assembler tags
          WT-2902 Enhance eviction to work better with update heavy YCSB load
          WT-2905 dead code: MongoDB Coverity #99881
          WT-2908 Add dry-run support to python unit-test
          WT-2910 test_inmem01 can abort due to stuck cache
          WT-2911 add support for gcc6
          WT-2912 make --enable-strict run on the zseries test box
          WT-2913 stuck cache after latest merge
          WT-2914 Fix link error on OS/X for checksum_init call
          WT-2916 whitespace check not working
          Branch: v3.2
          https://github.com/mongodb/mongo/commit/dfca65ea3a32b1e0c832ff7ee2d7b667819ec64d


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since reply:
                35 weeks, 6 days ago
                Date of 1st Reply: